Discussion:
Segmentation fault with Claws Mail
(too old to reply)
Johnny
2020-07-07 20:35:53 UTC
Permalink
Two or three times a day I have a segmentation fault with claws-mail.

Just wondering if anyone else has the problem, or might know what's
causing it.

When starting Claws Mail from a terminal, the last message before
the segmentation fault says nntp server disconnected.
Michael Bäuerle
2020-07-07 21:40:45 UTC
Permalink
Post by Johnny
Two or three times a day I have a segmentation fault with claws-mail.
Just wondering if anyone else has the problem, or might know what's
causing it.
I don't use Claws Mail as Newsreader, but I have such crashes too
with Mail (Version 3.17.4 on NetBSD/amd64). Maybe this is not News
related.

I have updated to 3.17.5 today, but not tested this version yet.
Johnny
2020-07-08 12:03:08 UTC
Permalink
On Tue, 7 Jul 2020 23:40:45 +0200 (CEST)
Post by Michael Bäuerle
Post by Johnny
Two or three times a day I have a segmentation fault with
claws-mail.
Just wondering if anyone else has the problem, or might know what's
causing it.
I don't use Claws Mail as Newsreader, but I have such crashes too
with Mail (Version 3.17.4 on NetBSD/amd64). Maybe this is not News
related.
I have updated to 3.17.5 today, but not tested this version yet.
I searched this website and found 32 different possible causes of
segfaults.

https://claws-mail.org/NEWS

This seems to be the one that's causing my problem.

* Bug fixes:
o bug 1032, 'Segmentation fault when showing message'
o fix crash with quote folding on HTML
o fix building with --disable-nls
o remove tabs in Subject string

I might try completely removing claws, deleting the directory,
compiling from source code with --disable-nls.
Michael Bäuerle
2020-07-08 16:21:30 UTC
Permalink
Post by Johnny
Post by Michael Bäuerle
Post by Johnny
Two or three times a day I have a segmentation fault with
claws-mail.
Just wondering if anyone else has the problem, or might know what's
causing it.
I don't use Claws Mail as Newsreader, but I have such crashes too
with Mail (Version 3.17.4 on NetBSD/amd64). Maybe this is not News
related.
I have updated to 3.17.5 today, but not tested this version yet.
I searched this website and found 32 different possible causes of
segfaults.
https://claws-mail.org/NEWS
This seems to be the one that's causing my problem.
o bug 1032, 'Segmentation fault when showing message'
o fix crash with quote folding on HTML
o fix building with --disable-nls
o remove tabs in Subject string
I might try completely removing claws, deleting the directory,
compiling from source code with --disable-nls.
The listed bugs were fixed in version 2.5.4.
Do you really think they show up again now?


No crash with 3.17.5 on my machine since the update.
Maybe it was this bug:
|
| * 3.17.5
| --------
|
| [...]
| * bug fixes:
| [...]
| o Fix crash in litehtml_viewer when <base> tag has no href
Poprocks
2020-07-08 17:41:39 UTC
Permalink
Post by Johnny
Two or three times a day I have a segmentation fault with claws-mail.
Just wondering if anyone else has the problem, or might know what's
causing it.
When starting Claws Mail from a terminal, the last message before
the segmentation fault says nntp server disconnected.
This isn't really enough information to try to troubleshoot.

Assuming you're using the latest version of Claws Mail, try rebuilding
it with debugging symbols enabled, and then run it through a debugger
such as gdb.

If what you're experiencing is a bug, you may then be able to provide a
meaningful bug report to the developers.

Loading...